Degraded / Service Interruption

Incident Report for Two River Technology Group

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 10:13 EDT

Update

Microsoft services have been restored and are now fully operational. Users should no longer experience issues with Outlook, Teams, or other Microsoft 365 apps.
Posted Oct 30, 2025 - 10:13 EDT

Update

We are continuing to investigate this issue.
Posted Oct 30, 2025 - 10:10 EDT

Investigating

Microsoft is currently experiencing an ongoing outage affecting Azure, Microsoft 365, and related services. Users may experience issues logging in, accessing portals, or using Microsoft 365 features.

Current Impact:

Some users may not be able to access Microsoft portals or applications.

Certain administrative features and add-ins may be temporarily unavailable.

Action Taken:
Our team is monitoring the situation closely. Microsoft is actively investigating the outage and working to restore full service.
Posted Oct 29, 2025 - 16:44 EDT
This incident affected: Venn (OS33) Workplace and Microsoft Office 365.